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INTRODUCTION

WHY MAKE YOUR OWN PAPER MAPS?

No batteries or data plans to worry about

100% customized!

All your travel info in one convenient book

Makes collaboration and including new information fun and easy

Gives you a cool souvenir!

WHAT WILL WE DO TODAY?

We will show you how we:

Work together to collect interesting points

Import points into QGIS

Import a background map into QGIS

Format the map

Make an index map and map tiles for your atlas

Put your atlas together in your word processor

By the end of today, you’ll have a printable map of Berlin that you can keep customizing!

TOOLS WE’LL USE

A web browser:

Google mymaps to easily collect and organize points of interest

BigMap 2 to generate background map tiles

QGIS to generate the printable maps

OpenLayers Plugin to make sure everything looks ok (very helpful for beginners!)

Atlas tool to automate exporting each page of your atlas as an image

A word processor to lay out your atlas (pages, but any word processor will do)
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SETUP: FOLDER STRUCTURE

Here’s the folder structure we use to keep our projects organized:

Berlin 2018 Trip (contains QGIS files, final pages doc of atlas)

Base Maps

Detailed Maps (contains .png and .kml of base map(s) for detailed maps)

Index Map (contains .png and .kml of base map for index map)

Exported Maps (contains exported .png files from QGIS)

Map Book Info (folder for info you want to include in the atlas - eg: weather forecast screenshots,

images to use to describe museums, city’s transport maps, etc.)

OSM Styles

Points (contains exported .kml from My Maps)

COLLECT YOUR POINTS OF INTEREST WITH GOOGLE MY MAPS

GOOGLE MY MAPS

1. Go to http://mymaps.google.com

2. Make a new map

3. Collect your points in layers

4. Group points in layers by type: everything in the same layer will look the same in your

finished map

5. Add useful descriptions to the points

Keeping your descriptions in My Maps helps keep the descriptions organized - you can copy them

from QGIS to your atlas at the end

Don’t worry about formatting your points on this map. We’ll do that in QGIS
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We made an example map for Maptime Berlin - 18 September 2018 which you can use to follow

along with us today.

Figure 1 Example map of Berlin for MaptimeWorkshop

EXPORT YOUR POINTS

1. Click on the menu button next to the title (see Figure 2)

2. Select: “Download kml”

3. In the window that pops up, select “Export to a .KML file”

4. Save the file in the “Points” folder



Make your own printable holiday maps!

By discosnail for Maptime Berlin, Sept 18, 2018

6

Figure 2 Shows where to find the menu button in step 1 (in a map you made, or a map shared by someone else)

BACKGROUND MAPS

We’ve now got the points we’re interested in, and in future steps we’ll add some boxes around the

areas we’re interested in, map labels, scale bars, etc. But just points and boxes won’t help us find our

way around the city. We need a “base map” that shows the underlying map data, like streets, subway

stations, rivers, parks, etc. We’ll download two for our atlas:

1. Index Map: A fairly zoomed out map that shows the whole city. This is the map you’ll look at

to see where to find the map showing details of the neighbourhood you’re interested in.

2. Detailed Map(s): A map that lets you see the details of the area. This one should have legible

street names, subway stops, etc. These are the maps you’ll look at when you’re actually

navigating to a restaurant / museum / etc.

The images we want to download will look like this:
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Figure 3 Index Map Base

Figure 4 Detailed Map Base

SET UP YOUR INDEX MAP

We’ll use BigMap 2 to make georeferenced images:

1. Go to http://bigmap.osmz.ru/

2. Zoom in until you can see most of Berlin

3. Select a map display type you like

4. Press “Submit” at the bottom of the page



Make your own printable holiday maps!

By discosnail for Maptime Berlin, Sept 18, 2018

8

Figure 5 Screenshot of BigMap 2

FINE TUNE THE MAP

Use the “Expand” and “Shrink” buttons to fine tune your index map if needed

Figure 6 Screenshot of fine tuning the map

When it looks right, click “Enqueue”
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Figure 7 The Enqueue tab will look like this

Opening this tab asks the server to generate a single georeferenced picture that exactly matches what

you saw in the previous tab.

Leave this tab open while you do the next step, then come back after a few minutes - we’ll remind you

below.

Note: Having 50 people request maps at once might slow this down! We’ve included the files you

need in the zip file you can grab from the meetup event page.

SET UP DETAILED MAP SET UP (SAME STEPS AS INDEX!)

1. Open a NEW TAB

2. Go back to http://bigmap.osmz.ru/

3. Zoom in until you can see an area that covers your points of interest

4. Select a map display type you like

5. Press “Submit” at the bottom of the page
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Figure 8 BigMap splash screen with an area highlighted that covers all of our points

FINE TUNE YOUR DETAILED MAP

1. Click on “in/double size” until you can read all the street names.

2. When it looks right, click “enqueue” again
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Figure 9 Fine-tuning the detailed map

DOWNLOAD YOUR BASE MAPS

1. Go back to the “enqueue” tab for your index map and reload it

2. Download both the .png and the .wld files

3. Save them in your “Base Maps/Index Map” folder*

4. Do the same with the detailed map, but:

5. Save those in the “Base Maps/Detailed Maps” folder*

*Don’t change the file names.

Figure 10 How to download your maps once enqueueing is done

.png .wld
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QGIS

Now we’ll set up our map in QGIS. In this chapter, we’ll walk you through the following steps:

1. Make a new project

2. Use OpenLayers to make an Open Street Maps layer (for troubleshooting)

3. Import our base map and points

4. Check everything is in the right place

5. Format our map

6. Generate maps for our atlas

OPEN QGIS AND MAKE A NEW PROJECT

We’re using QGIS 2.18.23 - the most recent version of the Long Term Release.

We haven’t tested this with later versions, but it should be a similar process!

Open up QGIS and make a new project (Project->New).

Save it in your project folder (File->Save As)

Figure 11 Making a new project
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TROUBLESHOOTING WITH THE OPEN LAYERS PLUGIN

To check if what you’ve imported is correct use can use the Open Layer plugin to show Open street

maps or Google maps data and make sure that the map you have imported was imported correctly.

Insert a dynamically updated open street maps layer: Web > Open Layers Plugin > Open Street Map >

Open Street Map

Figure 12 Using the OpenLayers Plugin to add an OpenStreetMap layer

INSERT YOUR BACKGROUND MAPS

1. Open your “Index Maps” folder in finder / your file browser

2. Drag the .png file into the QGIS window

3. A “Coordinate Reference System Selector” window will pop up. Press “Cancel” (do not press

OK!)*

4. Repeat 1-3 for the Detailed Map

5. Give these layers reasonable names (right click, and select Rename)

* This is weird but works consistently for us. Pressing OK will result in an INCORRECTLY PLACED

MAP. If anyone can tell us why, please let us know!

Figure 13 the Coordinate Reference System Selector Window - press Cancel!!

NO!
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IMPORT POINTS, AND CHECK LAYER ORDER

1. Open your “Points” folder in finder, and drag the .kml file into your QGIS window

2. In the window that pops up, make sure to select all the layers and then click OK.

3. Make sure your layers are in the right order in the “Layers Panel”:

a. Top: all the points layers from My Maps

b. Middle: your detailed map

c. Middle: your index map

d. Bottom: your “OpenStreetMap” layer

4. Toggle your layers on and off to compare them to the Open Layers layer. Make sure

everything matches!

Figure 14 Your Layers Panel should look like this

WHY NOT USE THE OPENSTREETMAP LAYER AS YOUR BASE MAPS?

Why do we import these base maps instead of using the Openstreetmap layer? That’s a good

question, and actually our earliest maps did just use the Openstreetmap layer. The problems with

this approach are:

� The plugin doesn’t consistently fetch base maps for your exported maps (meaning you have

to export each map multiple times until it looks right…)

� You can’t control the scale of the base map (so it looks extra pixelated)

Advanced solution: Another probably better option would be to import actual OSM data in vector

form and format it yourself. There are some styles you can even download to format the data nicely.

This would eliminate pixelation, but seems more difficult to us (we’ve never done it).

FORMAT POINTS

ICONS

Now its time to customize how your points look. Let’s start with our home.

1. Right click on the layer you want to change the icon for.

2. Go to Properties.

3. Under the Style tab, click on Simple marker.
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4. Change the Symbol layer type to SVG marker in the dropdown menu.

5. Change the Size to 10 mm

6. Select a Fill colour you like. We chose red.

Figure 15 How to change the marker type

The top half of this window is scrollable.

1. Scroll all the way down to the bottom. There you’ll see a SVG Image pane, with icons.

2. Choose an icon you like. We chose a house.
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LABELS

1. Select the Labels tab

2. Click on the drop-down menu at the top of the window that says No labels and select Show

labels for this layer instead

3. In the Label with dropdown, select Name

Figure 16 Labels Settings

1. Click OK and take a look at your map

2. Follow these steps for the other two layers on your map with different incons and colors.

FIDDLY BITS

How to fix common problems:

1. For labels on top of points:

a. In the Labels tab, select Placement

b. Increase the Distance (2mm works well with 10mm markers)

2. To increase text legibility:

a. In the Labels tab, select Buffer

b. Check the box next to Draw text buffer

3. To make sure your labels don’t show up on your index map:

a. In the Labels tab, select Rendering

b. Check the scale-based visibility box and set the maximum to 15000
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Figure 17 Where to find the commands listed in the "Fiddly Bits" list

MAKE BOXES AROUND DETAILED MAPS

1. Open the Vector Grid tool: Vector-> Research Tools -> Vector Grid

2. Click the menu button next to “Grid Extent” and select “Select extent on canvas”

3. Use your mouse to select an area that covers all your points of interest.

4. Set the X spacing to 2100 and the y spacing to 2900

5. Press Run
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Figure 18 Vector Grid Settings

FORMAT THE GRID

On this slide we’ll make sure that the Grid boxes look ok: the layers are in the right order, the boxes

have labels that will show up in the index map but not the detailed maps, etc.

1. In the layers pane, make sure Grid is under the points, but above the detailed map.

2. Open the properties of this new Grid layer

3. In the Style tab, click on Simple Fill

4. Click on the Fill dropdown and check the Transparent Fill checkbox
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Figure 19 Formatting your Grid layer

5. In the Labels tab,

6. At the top of the window, instead of No labels, select Show labels for this layer

7. Set Label with to the 123 id attribute

8. Increase the font size (I selected 18 point, Helvetica Bold)

9. Select Buffer, and turn the buffer on (default settings were fine for me)

10. Select Rendering and check the Scale-based visibility

11. Set the Minimum to 15000 (you’re looking for something between your index map scale and

your detailed map scale)
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Figure 20 Adding labels to your Grid layer

ADVANCED TRICKS

In a map book, each point will have reference information associated with it that allows you to find

that point on the map. For example, it will say, Angry Chicken can be found on Map 1, square E2. That

means that it’s on map 1, and map 1 has grid information allowing you to quickly zoom in to a

particular location to find the point, so look in square E2. You can definitely do this by hand, and

that’s what we’ve done in the past.

However, with a bit more work in QGIS, you can use the Vector->Data Management Tools->Join

Attributes By Location command to automate this. To do this, you need to make sure all your layers

have the same CRS. We haven’t got the time to describe this in detail (and have never done this yet

with our own map - but it’s our goal!) If you’re keen, you can probably figure this out yourself, and

eventually we want to add more detail to this section to lead you through it.

EXPORT INDEX MAP

1. Turn OFF the detailed maps layer

2. Go to Project->New Print Composer

3. Enter “Index Map” as the title and press ok

4. Click the Add New Map button and drag a box across your page

5. Grab the anchors and drag them about until the map fills the whole page

6. Click the Export to Image button
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7. Save your exported file into your Exported Maps folder as Exported Index

EXPORT DETAILED MAP USING ATLAS GENERATOR

SET UP ATLAS GENERATOR

• Close the map composer

• Turn your detailed map layers back on in QGIS map window

• Go to Project->New Print Composer

• Enter “Detailed Map” as the title and press ok

• Select Composition in the pane on the right

• Under Page Size find Orientation and set it to Portrait

• Click the Add New Map button and drag a box across your page. Make it fill the page like

you did for the Index Map

Figure 21 Detailed Map Composer - Portrait Orientation

1. Click on the Atlas generation tab

2. Check the Generate an Atlas box

3. Select your Grid layer as the coverage layer
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Figure 22 Atlas Generation Setup

1. Click on the Item Properties tab

2. Scroll down and check the Controlled by atlas box. This tells the composer that it should be

controlled by the Atlas tool, whose properties are defined in the Atlas Generation tab.
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Figure 23 Map Composer Item Properties for Atlas Generation

3. The preview image doesn’t look like the detailed map we want yet. To see what your

generated maps will look like, you need to go to Atlas -> Preview Atlas

4. Now the map refreshes and it should look like the detailed maps we want to export!

SWITCH BETWEEN DETAILED MAPS

You can see which map grid you’re working on now by looking in the bottom right corner of this

preview window. This tells you which feature of the coverage layer we’re currently looking at.

You can switch between detailed maps using the Atlas menu where you’ll find the following

commands:

Figure 24 Atlas Menu - switch between feature views
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Figure 25 What you should see now

ADD A LABEL AND A SCALE BAR

Now we’ll add some information to our map: a) a label that matches the ones shown on the index

map (Map 1, Map 2, etc.) and b) a scale bar.

1. Go to Layout -> Add Label

2. Click on your map where you want to add the label.

3. Select Item Properties

4. Delete QGIS from the text field

5. Click on Insert an expression...

6. Type concat(‘Map ‘, id) (this tells QGIS to label the map with the text Map 1 for the first box,

Map 2 for the 2nd, and so on.) Then click OK.
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Figure 26 Use a Formula to Generate Map Labels

7. Under Item Properties, look for the Font button. Click on it to set the font type, size, etc. (we

used Helvetica, Bold, 18pt.) Click OK.

8. If you can’t read your label, drag the anchors at the corners of the box to make it bigger

9. Go to Layout -> Add Scale Bar

10. Click on your map where you want to add a scale bar, and drag it around until you like its

position
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Figure 27 Map Composer with Label and Scale Bar

EXPORT DETAILED MAP

1. Once you are happy with how your map looks, go to Atlas -> Export Atlas as Images

2. Select the Exported Images folder to save your atlas images to

3. The default settings for resolution etc. are fine.
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EXPORT YOUR POINT INFORMATION

You can get the information out of your points layer by

1. Right-click on the layer, and select Open Attribute Table.

2. You can then select all rows

3. Copy the information (or keyboard shortcuts work).

4. There doesn’t seem to be a way to copy just certain columns of information, but if you paste

the copied cells into can use excel/numbers/openoffice, you can just grab the name and

description column,

5. Paste the information into your word processor. You probably want to paste as unformatted

text, unless you want your information to be displayed as a table.

SET UP YOUR MAP BOOK

GENERAL GUIDELINES FOR YOUR MAP BOOK:

• Page 1 will be the cover for your book.

• Page 2 should be blank

• Page 3 should be a table of contents

• Page 4 (and 5) should be your index map

• If Page 5 is not a continuation of your index map, leave it blank

• Pages 6+ should be your detailed map

• After that include sections for each of your point types (which you’ve pasted into your word

processor according to the instructions in the previous slide)

• After that, we like to include some useful information for travel to that location like phrases

in the language, currency exchange rates, transit maps, etc.

• Finally, we include a notes section where we write down what we did each day.

PRINT AS A BOOKLET

The easiest way is if your printer drivers allow you to print something as a booklet. This will

automate printing pages in order, etc. To be honest, a print shop’s printers will do this and you’ll get

all your pages in pretty colour in waterproof ink. That’s my preference!

Otherwise though, maybe you’re at home the night before your trip with only your shitty freecycle

printer to print with and if you don’t sort it now, you won’t have a map. We’ve all been there… Here

is the tool I’ve used in this context:

Print your booklet to pdf, then use LaTeX with pdftex to print it

http://www.mostlymaths.net/2008/09/latex-booklets.html
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Thank you!

Reach out to us if you have any questions!: info@discosnail.com

LINKS AND RESOURCES

Save your mapping points at: http://mymaps.google.com/

QGIS: https://www.qgis.org (we used version 2.18.23)

QGIS download page: https://www.qgis.org/en/site/forusers/download

Find background images for your maps: http://bigmap.osmz.ru

Automating Map Creation tutorial:

http://www.qgistutorials.com/en/docs/automating_map_creation.html

Step by step guide on how to make your own travel maps:

http://nicolesiggins.com/makeyourowntravelmaps

Making a PDF booklet that’s ready to be printed and folded:

http://www.mostlymaths.net/2008/09/latex-booklets.html

Other possibly helpful tutorials:

https://docs.qgis.org/2.14/en/docs/training_manual/forestry/forest_maps.html


